Ad Code

Responsive Advertisement

Uri - Beecrowd | 1042 | Simple Sort

beecrowd | 1042

Simple Sort

Adapted by Neilor Tonin, URI Brazil


Read three integers and sort them in ascending order. After, print these values in ascending order, a blank line and then the values in the sequence as they were readed.

Input

The input contains three integer numbers.

Output

Present the output as requested above.

Input Sample Output Sample

7 21 -14

-14
7
21

7
21
-14

-14 21 7

-14
7
21

-14
21
7

N.B.: It's better if you solve this by your own. Thank you!

  URI - BEECROWD Online Judge 1042 Solve  in C :                                          

//Solved by Intesar
#include <stdio.h>

int main() {

    int a,b,c;
    scanf("%d%d%d",&a,&b,&c);

    if(a<b && a<c){
        printf("%d\n",a);
        if(b<c){
            printf("%d\n%d\n",b,c);
        }
        else
            printf("%d\n%d\n",c,b);
    }
    else if(b<a && b<c){
        printf("%d\n",b);
        if(a<c){
            printf("%d\n%d\n",a,c);
        }
        else
            printf("%d\n%d\n",c,a);
    }
    else{
        printf("%d\n",c);
        if(a<b){
            printf("%d\n%d\n",a,b);
        }
        else
            printf("%d\n%d\n",b,a);
    }
    printf("\n%d\n%d\n%d\n",a,b,c);

    return 0;
}

Post a Comment

0 Comments

Ad Code

Responsive Advertisement