Ad Code

Responsive Advertisement

Uri - Beecrowd | 1041 | Coordinates of a Point

beecrowd | 1041

Coordinates of a Point

Adapted by Neilor Tonin, URI Brazil


Write an algorithm that reads two floating values (x and y), which should represent the coordinates of a point in a plane. Next, determine which quadrant the point belongs, or if you are at one of the Cartesian axes or the origin (x = y = 0).

Coordinates of a Point uri 1041

If the point is at the origin, write the message "Origem".

If the point is at X axis write "Eixo X", else if the point is at Y axis write "Eixo Y".

Input

The input contains the coordinates of a point.

Output

The output should display the quadrant in which the point is.

Input Sample Output Sample

4.5 -2.2

Q4

0.1 0.1

Q1

0.0 0.0

Origem

N.B.: It's better if you solve this by your own. Thank you!

  URI - BEECROWD Online Judge 1041 Solve  in C :                                          

//Solved by Intesar
#include<stdio.h>

 int main() {
  float X, Y;
  scanf("%f%f", &X,&Y);

  if (X == 0 && Y == 0) {
   printf("Origem\n");
  }else if (X == 0 && Y != 0) {
   printf("Eixo Y\n");
  }else if (Y == 0 && X != 0) {
   printf("Eixo X\n");
  }else if (X > 0 && Y > 0) {
   printf("Q1\n");
  }else if (X < 0 && Y < 0) {
   printf("Q3\n");
  }else if (X < 0 && Y > 0) {
   printf("Q2\n");
  }else  {
   printf("Q4\n");
  }
  return 0;
 }

Post a Comment

0 Comments

Ad Code

Responsive Advertisement