Ad Code

Responsive Advertisement

Uri - Beecrowd | 1049 | Animal

beecrowd | 1049

Animal

By Neilor Tonin, URI Brazil


In this problem, your job is to read three Portuguese words. These words define an animal according to the table below, from left to right. After, print the chosen animal defined by these three words.

Animal uri 1049

Input

The input contains 3 words, one by line, that will be used to identify the animal, according to the above table, with all letters in lowercase.

Output

Print the animal name according to the given input.

Input Samples Output Samples

vertebrado
mamifero
onivoro

homem

vertebrado
ave
carnivoro

aguia

invertebrado
anelideo
onivoro

minhoca

N.B.: It's better if you solve this by your own. Thank you!

  URI - BEECROWD Online Judge 1049 Solve in C:                                          

//Solved by Intesar
#include <stdio.h>
#include <string.h>
int main() {

    char str1[20],str2[20],str3[20];
    scanf("%s",&str1);
    scanf("%s",&str2);
    scanf("%s",&str3);

    if(strcmp(str1,"vertebrado")==0)
    {

        if(strcmp(str2,"ave")==0)
        {
            if(strcmp(str3,"carnivoro")==0)
                printf("aguia\n");
            else if(strcmp(str3,"onivoro")==0)
                printf("pomba\n");
        }
        else if(strcmp(str2,"mamifero")==0)
        {
            if(strcmp(str3,"onivoro")==0)
                printf("homem\n");
            else if(strcmp(str3,"herbivoro")==0)
                printf("vaca\n");
        }
    }
    else if(strcmp(str1,"invertebrado")==0)
    {
        if(strcmp(str2,"inseto")==0)
        {
            if(strcmp(str3,"hematofago")==0)
                printf("pulga\n");
            else if(strcmp(str3,"herbivoro")==0)
                printf("lagarta\n");
        }
        else if(strcmp(str2,"anelideo")==0)
        {
            if(strcmp(str3,"hematofago")==0)
                printf("sanguessuga\n");
            else if(strcmp(str3,"onivoro")==0)
                printf("minhoca\n");
        }
    }

    return 0;
}

Post a Comment

0 Comments

Ad Code

Responsive Advertisement