Ad Code

Responsive Advertisement

Uri - Beecrowd | 1047 | Game Time with Minutes

beecrowd | 1047

Game Time with Minutes

Adapted by Neilor Tonin, URI Brazil


Read the start time and end time of a game, in hours and minutes (initial hour, initial minute, final hour, final minute). Then print the duration of the game, knowing that the game can begin in a day and finish in another day,

Obs.: With a maximum game time of 24 hours and the minimum game time of 1 minute.

Input

Four integer numbers representing the start and end time of the game.

Output

Print the duration of the game in hours and minutes, in this format: “O JOGO DUROU XXX HORA(S) E YYY MINUTO(S)” . Which means: the game lasted XXX hour(s) and YYY minutes.

Input Sample Output Sample

7 8 9 10

O JOGO DUROU 2 HORA(S) E 2 MINUTO(S)

7 7 7 7

O JOGO DUROU 24 HORA(S) E 0 MINUTO(S)

7 10 8 9

O JOGO DUROU 0 HORA(S) E 59 MINUTO(S)

N.B.: It's better if you solve this by your own. Thank you!

  URI - BEECROWD Online Judge 1047 Solve in C:                                          

//Solved by Intesar
#include <stdio.h>
int main()
{
    int a, b, c, d;
    int dif;
    scanf("%d %d %d %d", &a, &c, &b, &d);

    dif = ((b*60)+d) - ((a*60)+c);

    if(dif<=0)
        dif += 24*60;
    printf("O JOGO DUROU %d HORA(S) E %d MINUTO(S)\n", dif/60, dif%60);

    return 0;
}

Post a Comment

0 Comments

Ad Code

Responsive Advertisement