Ad Code

Responsive Advertisement

Uri - Beecrowd | 1036 | Bhaskara's Formula

beecrowd | 1036

Bhaskara's Formula

Adapted by Neilor Tonin, URI Brazil


Read 3 floating-point numbers. After, print the roots of bhaskara’s formula. If it's impossible to calculate the roots because a division by zero or a square root of a negative number, presents the message “Impossivel calcular”.

Input

Read 3 floating-point numbers (double) A, B and C.

Output

Print the result with 5 digits after the decimal point or the message if it is impossible to calculate.

Input Samples Output Samples

10.0 20.1 5.1

R1 = -0.29788
R2 = -1.71212

0.0 20.0 5.0

Impossivel calcular

10.3 203.0 5.0

R1 = -0.02466
R2 = -19.68408

10.0 3.0 5.0

Impossivel calcular

N.B.: It's better if you solve this by your own. Thank you!


Bhaskara's Formula: 

Bhaskara's Formula



  URI - BEECROWD Online Judge 1036 Solve  in C :                                          

//Solved by Intesar
#include <stdio.h>
#include <math.h>
int main() {

    double a,b,c,d;
    scanf("%lf%lf%lf",&a,&b,&c);
    d = (b*b)-(4*a*c);
    if(d>=0 && a!=0)
    {
        printf("R1 = %.5lf\n",(-b+sqrt(d))/(2*a));
        printf("R2 = %.5lf\n",(-b-sqrt(d))/(2*a));
    }
    else
        printf("Impossivel calcular\n");

    return 0;
}

Post a Comment

0 Comments

Ad Code

Responsive Advertisement